Bug

  • Dieses Thema hat 1 Antwort und 2 Teilnehmer, und wurde zuletzt aktualisiert 5. Juli 2019 - 9:56 von Codemonkey.
Ansicht von 2 Beiträgen - 1 bis 2 (von insgesamt 2)
  • Autor
    Beiträge
  • #2292 Antworten
    Tobias Breiner
    Verwalter

    Hier ist eine Ferndiagnose schwierig, das ist ungefähr so als würde jemand beim Arzt anrufen, sagen, er habe Bauchschmerzen und danach fragen, was es ist. 😉

    Wenn es im CRoot::Tick abstürzt, kann dies viele Ursachen haben:

    1.) Fehlendes, falsches oder korruptes DirectX11-SDK (häufigste Urtsache)
    2.) Korrupte Node-Hierarchien
    3.) Korruptes Windows-SDK
    4.) Die Beispielapp findet die LIB nicht, weil du sie in einen anderen Ort kopiert hast
    5.) Die Shader-Files wurden überschrieben

    Vorgehen:

    1.) Schaue mal im LOG-File nach, ob irgendwelche Warning- oder Error-Nachrichten vorhanden sind. Diese geben meistens schon Hinweise auf die Ursache
    2.) Switche bei der Initalisierung des Frames auf eApiRender_Null, um DirectX aus- und dafür den Null-Renderer anzuschalten. Wenn es dann nicht mehr abstürzt, ist DirectX11 nicht richtig installiert, also
    m_zf.Init(hwnd, procOS, eApiRender_Null);
    3.) Ansonsten, wenn das alles nichts hilft, komme einfach mal mit deinem Rechner in meinem Büro vorbei!

    Viel Glück
    Tobi

    #2123 Antworten
    Codemonkey

    Hallo,

    Ich habe die Vektoria Beispielapp zum Laufen gebracht. Allerdings stürzt mir das Programm beim ersten Durchlauf in der Tick-Funktion ab. Sieht nach einem NULL Pointer Problem aus. Kann es sein, dass ich etwas nicht richtig installiert habe oder irgendetwas anderes falsch mache?

    LG!

Ansicht von 2 Beiträgen - 1 bis 2 (von insgesamt 2)
Antwort auf: Bug
Deine Information: